Jump to content

Welcome to Airsoft Forums UK
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. If you already have an account, login here - otherwise create an account for free today!
Photo

KWA MP9 Extremely Slugish cyclic rate


  • Please log in to reply
3 replies to this topic

#1
Jamoy

Jamoy

    AF-UK Newbie

  • Members
  • Pip
  • 3 posts

  • Guns: ICS AK74
    KWA Glock18c
    G&G GR16
    KWA MP9R

  • Loadouts: Templar Assault MOLLE Vest
    DPM British
Hey i recently baught a KWA mp9 and havent even skirmished it yet. Then suddenly it dosnt even fire! I mean when it fires it only has a velocity of maybe 240 fps which is not good. And sometimes the bolt and gas expansion chamber dosnt seem to seat properly. And on full auto it fires maybe 2 rounds then the entire magazine worth of gas is dumped in a massive woosh!

I have disasembled the gun to give it a clean then relubed it with some silicon spray. No use!

I have lost a small stupid pin that holds the trigger sear back like .4 mm further than it currently sits which should not be the deal as i have made a makeshift one and it made no difference.

I was using .2g ASG Blasters with Abbey Brut Sniper gas (Which kwas should be able to withstand)

What can the problem be? Cracked gas nozzle?

#2
Jamoy

Jamoy

    AF-UK Newbie

  • Members
  • Pip
  • 3 posts

  • Guns: ICS AK74
    KWA Glock18c
    G&G GR16
    KWA MP9R

  • Loadouts: Templar Assault MOLLE Vest
    DPM British

Hey i recently baught a KWA mp9 and havent even skirmished it yet. Then suddenly it dosnt even fire! I mean when it fires it only has a velocity of maybe 240 fps which is not good. And sometimes the bolt and gas expansion chamber dosnt seem to seat properly. And on full auto it fires maybe 2 rounds then the entire magazine worth of gas is dumped in a massive woosh!

I have disasembled the gun to give it a clean then relubed it with some silicon spray. No use!

I have lost a small stupid pin that holds the trigger sear back like .4 mm further than it currently sits which should not be the deal as i have made a makeshift one and it made no difference.

I was using .2g ASG Blasters with Abbey Brut Sniper gas (Which kwas should be able to withstand)

What can the problem be? Cracked gas nozzle?



It is the gas nozzle, The gas must be too high pressure. The nozzle was quite crap quality and barely a mm thick. Im going to write to KWA about this.

#3
REMSoft

REMSoft

    AF-UK Regular

  • Members
  • PipPipPip
  • 441 posts

  • Guns: TM Punisher MEU, TM G3, King Arms Blaser R93, CYMA RPK

  • Sites: Apocalypse airsoft Detling
    Elite Battlezone
Have you considered that you are using a gas weapon in winter?
QUOTE (PeteJC21 @ Oct 29 2011, 06:19 PM) <{POST_SNAPBACK}>
Does it come with a pair of sunglasses?

QUOTE
If the guy was unarmed and you ended up putting him in a blender you'll get in trouble.

#4
Rock-climby-Dave

Rock-climby-Dave

    Moderator

  • Moderators
  • PipPipPipPipPip
  • 2372 posts
It is loading the mag into the gun with the bolt forwards (uncocked).

To load an MP9 and NOT break it:
1. pull bolt back and apply bolt lock
2. put mag in to click
3. press bolt release.
4. KIIIILLLLLLLLLLLL

obviously, this is too late for you now, and it IS repair the gas nozzle jobby.

Send the doctors home, I'll be doing the operating around here.

 

Resident Patrol Base Techy, any questions about PB, message me and I'll do my best to answer.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users