Jump to content

Welcome to Airsoft Forums UK
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. If you already have an account, login here - otherwise create an account for free today!
Photo

Slide not sliding smoothly only after cocking


  • Please log in to reply
4 replies to this topic

#1
ucof

ucof

    AF-UK Newbie

  • Members
  • Pip
  • 7 posts

  • Guns: KWC P99 Springer

  • Loadouts: Green oil paint
    Leaves
    Sticks
    Glue
I bought a KWC Walther P99 springer ( http://www.kwcgun.co.../KA-25HW EN.jpg ), possibly about 12 years ago, but over the past 10 years or so, it has been rarely used.

I have recently come back to it however I have found that the top slide will always stick in place, but only if it has been fully cocked. If I pull it back to just before it cocks, and release it, it will snap back firmly. Note, this is not a "last round" issue.

I have completely stripped, cleaned and lubricated all moving parts (first with WD40 but then restripped and dried it before using baby powder (talc) as a dry lube) but it is still sticking.
I have stretched the spring (part no: S702) and put it back in place to give it a bit more "oomph", but it hasn't made any difference.

Does anyone have ideas what could be causing it?

#2
onion

onion

    AF-UK Regular

  • Members
  • PipPipPip
  • 303 posts

  • Guns: G&G m4 , G&P m13 a3

  • Loadouts: British dpm , Webtex assult vest , viper tac goggles
[firstly i think using wd40 :P thats a big no no in any gun , and most likley talc :P wd40 is a big no no with anything with rubber airseals etc
Harrys the name - Airsofts the game! G&P m16
<<>><<>><<>><<>><<>><<>><<>>

#3
ucof

ucof

    AF-UK Newbie

  • Members
  • Pip
  • 7 posts

  • Guns: KWC P99 Springer

  • Loadouts: Green oil paint
    Leaves
    Sticks
    Glue
Agreed, however it was late at night when I went about repairing it, hence why I stripped and dried it from any WD40 remnants when I realised about the implications.

Still not sliding back smoothly - I can only think that the spring has lost its' strength over the years.

Are there any other reasons why this might be happening?

#4
onion

onion

    AF-UK Regular

  • Members
  • PipPipPip
  • 303 posts

  • Guns: G&G m4 , G&P m13 a3

  • Loadouts: British dpm , Webtex assult vest , viper tac goggles
probly just old worn out , .. its just a cheap springer realy im quesing , its lasted this long :P
Harrys the name - Airsofts the game! G&P m16
<<>><<>><<>><<>><<>><<>><<>>

#5
smobrien

smobrien

    AF-UK Newbie

  • Members
  • Pip
  • 1 posts

  • Guns: g36
    g36c
    g36k
    m14
    m126
    p99 spring
    p99 gas
check for worn seals or slide lock not splitting
also check safty is intacked

on a different note been trying to find a spare mag for this pistol and no avail any ideas ???




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users