Jump to content

Welcome to Airsoft Forums UK
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. If you already have an account, login here - otherwise create an account for free today!

New gas gun problem - KJ Works

  • Please log in to reply
1 reply to this topic



    AF-UK Newbie

  • Members
  • Pip
  • 1 posts
Hello everyone,

Just got my first airsoft pistol and dont know too much about them but it does not seem to be working properly.
Its a full metal GBB Kj Works KP-07 which is basically a colt 1911 MEU version.
When I charge it up and start to fire the first few shots seem to throw out loads of gas, it is visible coming out the back and you can feel it on your face, it then starts to loose power and after a max of 15-20 shots will stop before emptying a mag with no gas left in the mag.
It also seems to have a problem loading the bb's, each mag you need to re c*** about 5 or so times to keep them coming out.
I am using a new can of H134a and what seem to be good bb's.

If anyone has got any ideas on how to fix it I would be greatfull,




    AF-UK Regular

  • Members
  • PipPipPip
  • 231 posts

  • Guns: CA M15CQB, TM 226, TM mk23 socom. All i need!!

  • Loadouts: loads but BFG's the best!!!!

  • Sites: UCAP's
is it new or sh??

has it been upgraded??

sounds like the hammer spring is to heavy. hence the heavy use of gas first few shots

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users